Όλες οι νέες και ενημερωμένες εφαρμογές στο Google Play Store θα πρέπει να υποστηρίζουν το Android 9 Pie μέχρι τα τέλη του 2019, δήλωσε η Google.

Από το 2017, η Google έχει δεσμευτεί για την βελτίωση της ποιότητας των εφαρμογών στο Android απαιτώντας την προσαρμογή σε ένα συγκεκριμένο επίπεδο API, ώστε να επωφεληθούν όλοι από τις νέες δυνατότητες της πλατφόρμας. Έτσι ορίστηκε το Android 8.0 ως στόχος που πρέπει να επιτευχθεί για όλες τις νέες και ενημερωμένες εφαρμογές από τον περασμένο Νοέμβριο. Σήμερα η Google μοιράστηκε στο Blog για Android Developers, ότι απαιτεί την εφαρμογή υποστήριξης για Android 9 Pie μέχρι το τέλος του τρέχοντος έτους.

Συγκεκριμένα, από τον προσεχή Αύγουστο, όλες οι νέες εφαρμογές που επιθυμούν να βρίσκονται στο Google Play Store θα πρέπει να υποστηρίζουν το API 28 ή νεότερη έκδοση. Μέχρι το Νοέμβριο, όλες οι νέες εκδόσεις εφαρμογών που βρίσκονται ήδη στο κατάστημα Google θα πρέπει να υπόκεινται στον ίδιο κανόνα. Αξίζει να θυμηθούμε ότι οι εφαρμογές του Google Play Store που δεν ενημερώνονται δεν χρειάζεται να προσαρμοστούν.

Διαβάστε επίσης:  Sharp Aquos R2: Ανακοίνωση του θηρίου στην Ιαπωνία, έρχεται Ευρώπη!

Σύμφωνα με την Google, η ενίσχυση αυτού του κανόνα θα αποφέρει οφέλη ειδικά στους τελικούς χρήστες των εφαρμογών. Για παράδειγμα, κατά το 2018 υπήρχαν πάνω από 150.000 εφαρμογές που υποστήριζαν τις νέες λειτουργίες του Android Oreo. Τα υπόλοιπα καταστήματα εφαρμογών Android είναι λιγότερο αυστηρά από το Google Play Store, π.χ. τα κινεζικά καταστήματα της Huawei, OPPO, Vivo, Xiaomi, Baidu, Alibaba και Tencent έχουν θέσει ως στόχο για το 2019 το API 26.

Η Google κινείται επίσης για να προστατεύσει το Android σε περίπτωση εγκατάστασης εφαρμογής μέσω sideloading. Διαπιστώθηκε ότι περισσότερο από το 95% των εξωτερικών spyware στο Play Store υποστηρίζει API 22 ή χαμηλότερο για να αποφύγει τα δικαιώματα εκτέλεσης εφαρμογής. Για το λόγο αυτό, για την προστασία από κακόβουλα προγράμματα, το Google Play Protect θα προειδοποιεί τους χρήστες όποτε προσπαθούν να εγκαταστήσουν αρχεία APK που δεν υποστηρίζουν πρόσφατο API. Συγκεκριμένα, από τον Αύγουστο του 2019 θα εμφανιστεί η προειδοποίηση για νέες εφαρμογές που δεν υποστηρίζουν επίπεδο API 26 ή υψηλότερο, από τον Νοέμβριο του 2019 θα αφορούν και τις νέες εκδόσεις των υπαρχουσών εφαρμογών. Το απαιτούμενο επίπεδο API προφανώς θα αλλάζει από έτος σε έτος.

[Πηγή] :

Gizchina